Skip to main content

News

  • Welcome to DeepThought!  Make yourself at home!

Topic: Recent time-outs are resolved (Read 283 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • oblivion
  • [*][*][*][*][*]
  • Administrator
Recent time-outs are resolved
During the last few days, the whole mcfrye.com site, including this forum, has been slow due to a software problem the web host was working on.  Here's the deets

Quote
We have, unfortunately, been experiencing issues with the S1 server over the last week. We believe the issue to be in the LiteSpeed Web Server Software on S1.

We have configured the server to switch to Apache+LSAPI [keeping many of the benefits of LiteSpeed, while using Apache at the core]. This should have been seamless but I personally failed to communicate this to our team effectively resulting in them working to restore LSWS when I switched it to Apache.
 
Ultimately the miscommunication on my part is the reason for the outage.
 
We are testing/monitoring the server's performance with Apache 2.4 + MPM Event.  One of the primary reasons we switched away from Apache many years ago was due to how resource intensive and bloated Apache was to accomplish the same goals.  At the time we were limited to systems with 2 to 8 GB of ram so being conservative of resources was a huge benefit and being faster was great as well.
 
At this point we're running machines with 100GB of ram or more - often 20 to 50GB of ram just not doing anything at all.  As such we don't mind so much the extra resource usage of Apache if it performs better/more reliable than LiteSpeed.
 
Many of the issues we've faced over the last 6 months have been LiteSpeed related - be it compatible with CentOS7 or simply bugs we've found and had to work to have resolved.
 
If you have any issues with any of your sites please let us know.

The site is pretty zippy now.  Hopefully it will stay that way.